Kill IE6

评分 4.0, 满分 5 星142
Loading...
添加评论

Internet Explorer 6 is outdated and insecure, it has stifled innovation long enough, Let's Kill IE 6!

Adding the NOTIFICATION on your site to help phase out Internet Explorer 6 forever. They tells visitors using Internet Explorer 6 that they need to upgrade to the current version or switch to another browser right now.

Let's Kill IE6

中文使用说明请看文章《IE6 必死》的结尾部分: http://www.neoease.com/ie6-must-die/

Install On Your Website

Let's kill Internet Explorer 6, copy and paste this code before your closing </html> tag.
(Let's Kill IE6 script is support both HTTP and HTTPS protocol.)

English
Demo

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/default.js"></script>
<![endif]-->

简体中文
Demo

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/zh_CN.js"></script>
<![endif]-->

繁體中文
Demo | Translated by Cracky冰

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/zh_TW.js"></script>
<![endif]-->

Arabic
Demo | Translated by Abdullah

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/ar.js"></script>
<![endif]-->

Brazillian Portuguese
Demo | Translated by Franklim Pagung

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/br_BR.js"></script>
<![endif]-->

Catalan
Demo | Translated by àlvar Cuevas i Fajardo

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/ca_ES.js"></script>
<![endif]-->

Dutch
Demo | Translated by Gert Hengeveld

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/nl_NL.js"></script>
<![endif]-->

Finnish
Demo | Translated by Legacy

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/fi.js"></script>
<![endif]-->

French
Demo | Translated by Simon Pireyn

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/fr_FR.js"></script>
<![endif]-->

German
Demo | Translated by Andre

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/de_DE.js"></script>
<![endif]-->

Greek
Demo | Translated by Konstantinos Rousis

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/gr.js"></script>
<![endif]-->

Hindi
Demo | Translated by Abhishek Mandloi

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/hi_IN.js"></script>
<![endif]-->

Hungarian
Demo | Translated by Muzsi János

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/hu_HU.js"></script>
<![endif]-->

Italian
Demo | Translated by Rui

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/it_IT.js"></script>
<![endif]-->

Indonesia
Demo | Translated by Arif N

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/id_ID.js"></script>
<![endif]-->

Japanese / 日本語
Demo | Translated by lovee

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/ja.js"></script>
<![endif]-->

Javanese
Demo | Translated by Sagung Aditya

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/javanese.js"></script>
<![endif]-->

Malay
Demo | Translated by Zubir Jamal

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/ms_MY.js"></script>
<![endif]-->

Norwegian
Demo | Translated by Ingebjørg Synnøve Thoresen

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/nb_NO.js"></script>
<![endif]-->

Polish
Demo | Translated by Cezar

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/pl_PL.js"></script>
<![endif]-->

Portuguese
Demo | Translated by João José

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/pt_PT.js"></script>
<![endif]-->

Romanian
Demo | Translated by Adrian Sandu

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/ro_RO.js"></script>
<![endif]-->

Russian
Demo | Translated by Alexandr Sinitsin

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/ru_RU.js"></script>
<![endif]-->

Spanish
Demo | Translated by Coco

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/es_ES.js"></script>
<![endif]-->

Swedish
Demo | Translated by J. Nyman

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/sv_SE.js"></script>
<![endif]-->

Thai
Demo | Translated by ThaiAnime

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/th.js"></script>
<![endif]-->

Turkish
Demo | Translated by Ahmet Polat

<!--[if IE 6]>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/tr_TR.js"></script>
<![endif]-->

Configuration

Now, you can change the disabled days with the JavaScript sentence.

var LETSKILLIE6_DELAY=30;

For Example

Adding the following line to your site, the notification will be disabled in the coming 14 days (default: 30 days) when visitors close it.

<!--[if IE 6]>
	<script>var LETSKILLIE6_DELAY=14;</script>
	<script src="//letskillie6.googlecode.com/svn/trunk/2/default.js"></script>
<![endif]-->

Help Kill IE6

Kill Internet Explorer 6, we need your help. If your language is not listed HERE and you want to contribute a translation, please translate the following sentences and send me the translation via Email (wuzhao.mail@gmail.com).

You're using Internet Explorer 6 to browse webpages right now, our website will work better for you if you upgrade to Internet Explorer 8 or switch to another browser.

BTW, don't forget to tell me which language you have translated.

使用连接器登录:

使用新浪微博登陆

评分 4.0, 满分 5 星142
Loading...

  1. ie6 前端人员的噩梦啊

  2. thanks a lot for that

  3. This is good tnx very much

  4. it's amazing blog and thanks for sharing .
    Thanks

  5. Tnx man for this

  6. thanks a lot for that

  7. 应该提倡使用IE9了。

  8. 必须KILL掉IE6, 不过随着微软解除对XP的支持,IE6也会越来越少的,之前做了个模型模拟,推算出大概15年底IE6使用量就可以基本上忽略了。

  9. google背墙怎么破

  10. Google的脚本,在天朝无能为力。呵呵

  11. @Leniy
    他测试页面为了让你看效果没做IE6判断的,所以你能看到提示。。。。

  12. 现在是不是该let's kill ie8了。

  13. 脚本太老了。ubuntu+chrome26也提示我用的ie6

  14. 这个插件对chrome不兼容

  15. 随他去吧,IE6退出历史舞台是迟早的事情

  16. 真全。。。。。过几年XP没了,就完全IE9+ 就完美了。。就全部Html5 css3了。。

  17. 很好的工具!

  18. 位置太不明显了吧,而且关闭后不再显示了。最好这一点可以自己定义

  19. IE6、7、8,都早该滚蛋了!

  20. IE6用户太多,还是得照顾,这个已用上

  21. 我是在另一个网站上看到这插件的,我也想屏蔽IE6,但是这个JS是不是有点问题。。。我用的是Mac上的safari访问那个网站的,然后这个JS就跳出来说“您正在使用 Internet Explorer 6 浏览网页,如果您 升级到 Internet Explorer 8 或 转换到另一款浏览器,可以获得更好的网站浏览体验。”,我很无语啊。。

  22. 做过网站几乎用不到这个,因为好久没遇到IE6进来的了,国内的老顽固太多:)

  23. 我的博客是直接屏蔽了IE6浏览器

  24. 诛杀IE6,人人有责!

  25. 找到组织了!
    尼玛IE6、7、8都该被killed!
    如果继续容忍这些恶劣的浏览器存在,那将是互联网的倒退!

  26. @T
    提倡IE10预览版。。。

  27. 现在Kill IE7也很有必要!!!

  28. @爆炸
    那这里 Demo 你看到是正常的吗? 有问题留个网址吧...

  29. 为什么在IE6里一直调用不出来?一直是无样式的文字出现。

  30. 应该提倡使用IE9了。

  31. @louis
    如果你有用路由器,那可能就是路由器的问题了,升级一下路由器。

  32. @louis
    你说用了这个组件还是 Demo 如此现实? 如果是 Demo 那是正常的, 因为那是做给你看的, 如果是你用了组件在 IE9 上也能看到, 请检查有没有限定只让 IE6 显示, 代码如下:

    <!--[if IE 6]>
    	// 在 IE6 中使用的 JavaScript
    <![endif]-->
  33. 为什么我用的是ie9却显示我用的是ie6???

  34. i hate ie6, kill it.

  35. 最近在折腾CSS3的新特性,真想把IE6/7/8都给kill掉,有木有!!!

  36. 特意前来耍耍

  37. 高级浏览器就不会走

  38. @user agents
    见维基百科条目 条件注释。。。

  39. @刚哥
    你 Out 了。。。

  40. 好强大的技术帝

  41. @user agents 加个[if IE 6] 如果是高级浏览器就不会走这一句,也就不用加载这个js

  42. @user agents
    不明白,为什么在页面里加个[if IE 6]来判断,如果去掉这个,JS里的判断就不起做用。

  43. 奇怪,我在火狐上安装user agent switcher 设置为IE6,此站不显示提示,而HAO123上显示,怎么回事???

  44. IE8下载地址已然不对了。

  45. 每次进来都提醒这个,叫我这个还在用IE6内核的情何以堪

  46. @mg12
    哦 ,这个png的图片上次没看到

  47. @mg12
    折腾呗,每天总有一些人刚刚接触html css javascript php wp ............
    慢慢的从被代码折腾,到每天折腾代码,慢慢成为老鸟。

  48. @selftown
    既然你不懂 JS 和 CSS, 为什么还要自己改? 你还要改 CSS 代码, 引用的图片.

  49. @mg12
    只需要修改这一行么?
    cssUrl :'//letskillie6.googlecode.com/svn/trunk/2/zh.css',
    写入正确的路径后,可以显示正常的框架和文字,但图片不能显示

  50. @selftown
    你需要进入 JS 文件, 修改一下 CSS 指定的地址. 配置在 JS 文件最底部.

    @tiger
    I want to kill the IE6 first, but I plan to create a new widget for the IE6 & IE7 next step.

1 3 4 5
  1. Loading...

文章浏览记录
正在加载...